VMWare Fusion 4.1.3 does not accept Bootcamp installation

I’m currently switching from Windows 7 to Windows 8 and I wanted to make a clean install. Therefore I completely removed the Bootcamp Partition with the Bootcamp assistent of Mac OS X. However, it could not remove the partition. I’ve decided to delete the partition manually and to recreate the partition.

The Mac OS X disk utility only allows me to create exFAT or FAT partition, because NTFS is not natively supported. I’ve decided to use ExFAT and deleted my old Windows 7 installation. After installing Windows 8, I wanted to use my Bootcamp installation on Mac OS X. So I started VMWare 4.1.3 (The latest version is 5, but I’m not willing to buy the upgrade, the old version works fine under Mountain Lion.), removed the old entry for my Windows 7 Bootcamp installation and wanted to create a new one.

But this failed with several error messages, indicating that the Bootcamp disk could not be configured. After a short Google search, I’ve found the problem with the exFAT format of the Bootcamp partition: VMWare Fusion only supports NTFS formatted partitions.

 

The lessons learned from my experience:

  • If you create the Bootcamp Partition with the Mac OS X assistent, you will get a 32GB large Partition in the correct useable format.
  • If you delete yourself old Bootcamp partitions and want to reinstall, make sure you format the partition with NTFS instead of any other offered formats. Instructions for this can be seen here.
  • If you use Paragon NTFS4Mac or if you use MacFuse, you could preformat the partition with NTFS. But Windows 7 and 8 want to create a small boot partition for themself, so I would not recommend to go this path. Format the partitions from Windows setup.

 

A small update:

I was not able to use VMWare again with Bootcamp. Therefore I decided to delete the partition with the Bootcamp assistent, which crashed during this operation. I had to enter the recovery mode of Mac OS X and had to recheck and repair the complete HDD and its partition. I’ve then changed the size of the HFS+ Volume on the HDD back to its original size and created a new Bootcamp partition using the assistent:

Creation of a  Bootcamp partition on Mac OS X 10.8
Creation of a Bootcamp partition on Mac OS X 10.8

 

Next Update:

No good news to report… Windows was finally recognized correctly by VMWare, but I couldn’t add the Bootcamp installlation. The setup wanted me to reboot into Windows and reboot into Mac OS X, because it thought the Bootcamp partition was not cleanly unmounted:

Bootcamp partition is not prepared - VMWare Fusion 4.1.3
Bootcamp partition is not prepared – VMWare Fusion 4.1.3

 

So I decided to try the new VMWare Fusion 5.0.1 version and suddenly my problems were all gone… It’s sad to see, that you always need a newer software version to work correctly. Especially when Windows 8 runs just fine inside a normal VMWare VM, but not when you are using Bootcamp. My guess would be that you could install Windows 7, configure Bootcamp correctly in VMWare Fusion and then upgrade to Windows 8. But this takes awefully long, so I’ll stick to the newer Fusion version. You can test it 30 days for free and after that you have to buy it for 44,99Euro 🙁

 

Windows 8 Developer Beta & VMware Fusion 4

This time it’s in english 😉 I hope that this will get me faster answers than if I would write it in german. So bear with me please 🙂

Today Microsoft released a public developer beta of Windows 8. I thought it would be nice to test, so I decided to install it on my Macbook Pro with Lion running. Windows 7 runs fine in VMware Fusion 3, however a Windows 8 VM will not boot. You will always get an error like „vcpu-0:NOT_IMPLEMENTED“. Reading this post about configuring Virtual Box, I thought this problem would have something to do with Intel VT-X extensions. However this setting did not fix the problem. Only todays update for Fusion 4 will let you use Windows 8.

I upgraded my Fusion installation and tried my old Windows 7 VM. It works just fine. So I gave Windows 8 another try and configured a new VM, just to be sure. With this VM I am able to start the graphical setup of Windows 8, however it will always ask me for a CD/DVD driver:

I tried using IDE and SCSI HDD configuration, but that did not change anything. The DVD drive is a mounted ISO image, from which the setup boots. I wonder myself why the Windows setup asks for a driver, if it boots from the asked device… anyways I don’t know what else can be done. I already tried to mount the VMware Tools installer (it’s just another ISO mounted to the DVD) and pointed setup to the drivers folder on that ISO image, but setup does not find any drivers at all.

Any hint on solving this problem would be highly appreciated 🙂

VMWare Fusion 3.1.3 und spontane Fehler

Ich verwende zur Zeit VMWare Fusion in der Version 3.1.3 als Virtualisierungslösung auf meinem Mac. Dabei benutze ich täglich eine Windows 7 VM für die Entwicklungsumgebung in meiner Masterarbeit. Gestern Abend habe ich die VM einfach nur angehalten und wollte heute Mittag weiter arbeiten. Doch dann begrüßte mich VMWare mit folgender Fehlermeldung:

VMWare Fusion kann keine Verbindung mit der virtuellen Maschine herstellen. Stellen Sie sicher, dass Sie über die erforderlichen Berechtigungen zum Ausführen des Programms und Zugreifen auf sämtliche Verzeichnisse verfügen, welche die Software verwendet, sowie auf alle Verzeichnisse mit temporären Dateien.

Also habe ich erst einmal einen großen Schrecken bekommen und habe überlegt, was wohl das Problem sein könnte. Ich habe dann das Festplatten Dienstprogramm meine Festplatte überprüfen lassen, es wurden aber keine Probleme in den Dateien der VMWare Installation oder der VM gefunden. Eine Google Recherche ergab dann, dass schon mehrere Leute dieses Problem hatten und man sollte doch einfach VMWare Fusion Neuinstallieren.

Das habe ich natürlich dann auch ausprobiert und habe allerdings keinen Systemneustart durchgeführt. Nach dem Neuinstallieren kam die Fehlermeldung noch immer. Auch nach einem Neustart blieb die Fehlermeldung, so dass mir eigentlich nur noch ein Weg eingefallen ist: Deinstallieren, herunterfahren und ausschalten, anschließend Neustarten und wieder VMWare installieren. Und tatsächlich, dieser Weg hat funktioniert. Die VM konnte wieder gestartet werden. Ich habe die VM erst einmal komplett heruntergefahren und habe mal wieder ein Backup gemacht. Das ist leider immer sehr zeitraubend, da sie mittlerweile 40GB groß ist und ich nicht nur die Differenz sichern kann, da ich nicht weiß, welche Dateien alle von VMWare verändert werden. Wenn hier jemand weiß, wie man das umgehen kann: ich bin offen für Anregungen.

Die Moral von der Geschichte: Auch wenn einem die Programme glauben lassen, man benötige keinen Systemneustart: Einfach mal zwischendurch Neustarten hilft scheinbar immer noch, auch bei einem Mac.

Nikon D40 Kamera Icons

Als stolzer neuer Besitzer einer Nikon D40 brauchte ich etwas mehr Farbe und Style auf meinem Mac 😉

Daher hab ich ne Runde gegooglet und habe dann hier dieses schöne Nikon D40 Icon Set gefunden. Damit kann man wunderbar das Icon von iPhoto und dem Datenträger selber auf dem Desktop ersetzen. Eine schöne Sache, wie ich finde 🙂

Übrigens: Es sind auch ein paar Icons für die Windows User dabei…

Apple Bootcamp, Windows XP und das Service Pack 3

Leider mag mich das Setup des SP3 wohl nicht. Das heute endlich offiziell erschienene Service Pack 3 für Windows XP sollte normalerweise unproblematisch in der Installation sein.

Apple hat vor wenigen Tagen auch seine BootCamp Treiber aktualsiert auf die Version 2.1 um auf das SP3 vorzubereiten.

Nachdem ich die Treiber nativ im BootCamp installiert hatte lief alles nach wie vor einwandfrei. Die neue VMWare Fusion Version lief auch ohne Probleme. Was aber Probleme machte war jetzt die SP3 Installation direkt unter BootCamp.

Das Setup wirft mir vor, einen nicht offiziellen Windows Kernel zu verwenden und man sollte in einem dazugehörenden Knowledge Base Artikel (Nummer gerade nicht zur Hand) nachgucken. Der Artikel besagt halt, dass man die boot.ini auf evtl. kernel= Einträge überprüfen soll und diese entfernen soll.

Eine damalige Parallels Installation hatte mal an dem boot Menü rumgespielt und die boot.ini entsprechend verändert. Dass dort Einträge stehen weiß ich, jedoch sind diese überlebenswichtig zum Booten. Ich hatte mal den Fall, dass ich den Parallels Eintrag entfernt hatte (und einfach nur BootCamp starten wollte) und das Windows dann nicht mehr booten wollte und mit einer Fehlermeldung stehen blieb.

Beim Suchen ist mir gerade noch diese schöne Seite aufgefallen, jedoch bringen mir die ganzen Tipps zum Installieren auch nichts, da ich an der Konfiguration so nichts ändern kann.

Mein einziger Plan im Moment wäre Windows neuinstallieren mit einer geslipstreamten Windows CD. Aber das wäre ja wieder zuviel Arbeit alles neuzuinstallieren… Vermutlich wird man das früher oder später bei der neuen VMWare Fusion Beta 2 dann wohl auch machen müssen.

Nachdem mir dann von zwei Freunden auch gerade ihr Patch Misserfolg mitgeteilt wurde was Windows auf normalen PCs angeht lasse ich erst mal die Finger vom SP3. Schade eigentlich…