Fritzbox 3270, Freetz und OpenVPN

Im Zuge meiner bereits erwähnten Umstellung auf ADSL2+ mit einer 16MBit Leitung habe ich meine AVM Fritzbox 3270 mit einer neuen Version des Freetz Mods bespielt. Ziel dieser ganzen Aktion war eigentlich nur die Möglichkeit von außen auf Geräte hinter meiner Fritzbox zuzugreifen. Früher habe ich das schon relativ bequem mit einem SSH Portforwarding lösen können. Dieses Mal wollte ich jedoch mehr und wollte mir extra OpenVPN auf die Box installieren.

Wenn man Freetz benutzen möchte, so sollte man sich am besten die Virtuelle Maschine Freetz-linux herunterladen und damit experimentieren. Diese VM basiert auf Ubuntu und besitzt bereits alle notwendigen Pakete für die Kompilierung der Firmware. Ich verwende speziell die freetz-trunk Version, welche immer den neuesten SVN Stand der Entwicklung wiedergibt. Diese habe ich speziell deswegen gewählt, weil ich somit die neusten Features (wie z.B. HFS+ Datenträgerunterstützung) aktivieren kann und auch die neueste Firmware 04.86 nutzen kann. Die Stable Version benutzen alle noch die ältere 04.80, in der z.B. das Gäste Wlan und keine IP v6 Unterstützung enthalten sind.

Nach vielen hin und her habe ich dann letztlich eine passende Pakete Auswahl getroffen, die auch nicht zu groß für den internen Speicher meiner Fritzbox ist. Ich musste dann die Firmware flashen und habe mich dann den ziemlich ungenauen Anleitungen des Freetz Wiki entlang gehangelt.

Damit begann das Elend… Fritzbox 3270, Freetz und OpenVPN weiterlesen

Ubuntu 9.04 unter VMware Fusion 2.0.4

Es war ja irgendwie so klar. Kaum installiert man ein Betriebssystem, das neuer ist als das verwendete VMware, hat man direkt wieder Probleme mit den VMware Tools. Ich konnte nicht meine Mouse über den Fensterrahmen ziehen und DragnDrop ging auch nicht.

Auch ein etwaiges Update mit dem Ubuntu Paket Manager brachte mich nicht weiter.

Erst einiges Googlen führte dann zu diesem interessanten Artikel bei VMware im Entwicklerblog. Demnach muss man einfach nur
sudo apt-get install xserver-xorg-input-vmmouse
anschließend einmal rebooten und der Mousezeiger funktioniert wieder ohne lästiges CTRL+Command drücken.